Loading...

qDiscussionView reply form

Home Forums QuickApps Forum qDiscussionView reply form

This topic contains 5 replies, has 2 voices, and was last updated by  Deepak Tyagi 8 months ago.

  • Author
    Posts
  • #10998

    Wendy
    Participant

    Greetings,

    I’ve created a qDiscussionView to view a Discussion Board.  I’ve created 3 qListForms – 1 for New, 1 for Edit, and 1 for Reply.

    The New and Edit forms work as expected on a Discussion.

    The Reply form set in ezEdit to display Discussion Subject, Body and Attachments.  Instead, it displays all attributes of the Discussion Board:  Discussion Subject (which is blank), Version, Body, Reply, Post, Threading, Modified By, Posted By, E-Mail Sender, Parent Item Editor, Parent Item ID, Attachments.  All attributes are blank except for Parent Item Editor and Parent Item ID.  I would expect the reply form to display Discussion Subject, Body and Attachments.

    When I enter data into Body, the reply is saved correctly.

    The same thing is happening when I edit a reply.

    Is there a way to remove all of those other attributes from the edit and reply forms?  Is there a way for Discussion Subject to display when replying?

    Thank you,

    Wendy

  • #10999

    Deepak Tyagi
    Participant

    Hi Wendy,

    You can remove other attributes from the edit and reply forms by following below steps:-

    1.          Open EzEdit of qlistform View webpart.
    2.          Go to display field screen.
    3.          Select Content Type as “message” from Content Types dropdown, available at top of the display field screen.
    4.          Select display fields.
    5.          Save all configuration

    We are analyzing your other issue  “Is there a way for Discussion Subject to display when replying?”.

    We will get back to you soon on this issue.
    Thanks
    Deepak

  • #11003

    Wendy
    Participant

    Thank you!  Adding fields on the “message” Content Type got rid of the extra fields.

     

  • #11004

    Deepak Tyagi
    Participant

    Hi Wendy,

    Thanks for reply.

    We analyzed your other issue “Is there a way for Discussion Subject to display when replying?”

    Yes, we can do that but we have to create a new reply page and add two new qListForm web parts. Please follow the below steps:

    1. Create a new page.
    2. Add new qListForm webpart and configure the discussion list.
    3. Set form type as form is “DisplayListItem” and Configure subject, discussion subject fields for in display field.
    4. Set ID HTTP Parameter Name as “DiscussionParentID”
    5. Set “NONE” in Toolbar Location from Appearance à Toolbar screen
    6. Save configuration.
    7. Add another qListForm webpart on same page.
    8. Configure the discussion list and set form type as “NewListItem”
    9. Configure Reply field in display field.
    10. Save configuration.

     

    Now open ezEdit of Discussion view webpart and click edit on Viewed Lists and then click on edit under list title and enter newly created page URL under “Reply Form URL” field and save it.

    Please let us know if you face any difficulty.

    Thanks

    Deepak

  • #11006

    Wendy
    Participant

    Hi Deepak,

    Thank you for the reply, it makes a lot of sense.  The only issue I’m  having is I can’t get Subject to display in the DisplayListItem web part.  Discussion Subject displays correctly for the replies but not for the initial discussion entry (which I guess is expected even though I don’t like it!).  Subject does not display at all.

    In the DisplayListItem web part, for Primary Content/Display Fields, I’ve selected Discussion Subject and Subject for Content Type Discussion.  I’ve selected Discussion Subject only for Content Type Message; Subject is not available.

    Please advise.  And thanks again for the suggestion.

    Wendy

  • #11008

    Deepak Tyagi
    Participant

    Hi Wendy,

    We analyzed your query and we would like to inform you that this is a current product behavior, but we have forwarded your valuable feedback to the Product team and they will try to incorporate this in the future releases of our product.

    Thanks
    Deepak

You must be logged in to reply to this topic.