Loading...

Unexpected Error on qDiscussionView

Unexpected Error on qDiscussionView

Home Forums QuickApps Forum Unexpected Error on qDiscussionView

  • This topic is empty.
Viewing 2 reply threads
  • Author
    Posts
    • #4112
      Anonymous
      Anonymous
      Participant

      After restoring a backup from UAT environment to PROD, when a web part page is access we get the attached error.  “An unexpected error has occurred”  We have looked at the web and front end servers and all have session state enabled (per earlier items in this discussion board).  Please advise.

    • #5068
      Anonymous
      Anonymous
      Participant

      reinstall of web parts corrected the issue

    • #5066
      Anonymous
      Anonymous
      Participant

      Hi Carrie,

      There are a few things you need to check/perform:

      – 

      After you install the product, locate the web.config file for your SharePoint Web application that has the Quest Shared Web Parts installed. You will need to make the following changes to it:

      1. Under the node, '<configuration><SharePoint><SafeControls>', the following entry should exist.
          '<SafeControl Namespace="WA.WebPart" Assembly="WA.WebPart, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2b4b09f1c57c8f0b" TypeName="*" Safe="True" />' 

        If this entry is not there, please go to the SharePoint administration page and redeploy the Quest Shared Web Parts Solution Package.

      2. Under the node, '<configuration><system.web><httpHandlers>', check if the following entry exists. If not, please add. 

        '<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
        <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />'

      3. Under the node, '<configuration><system.web><httpModules>', check if the following entry exists. If not, please add.
         

        '<add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />'

      4. In order for the Shared Web Parts to be fully functional you need to enable the session. To do so, please add the following entry under the node, '<configuration><system.web><httpModuels>', for SharePoint 2007 or, '<configuration><system.webServer><modules>', for SharePoint 2010: 

        '<add name="Session" type="System.Web.SessionState.SessionStateModule" />'

        and under the node, '<configuration><system.web><pages>', change the attribute 'enableSessionState' to true

      You can find all these steps in the readme file that comes with the product

      – to find out the reason of the SharePoint exception open the SharePoint log file and locate the cause of the error (you can use ULSViewer application available here http://archive.msdn.microsoft.com/ULSViewer) to make this process easier

      Please let me know how it goes.

      Thanks,

Viewing 2 reply threads

You must be logged in to reply to this topic.