Loading...

RE: DiscussionView Web Part Issues with SP 2010

RE: DiscussionView Web Part Issues with SP 2010

Home Forums QuickApps Forum DiscussionView Web Part Issues with SP 2010 RE: DiscussionView Web Part Issues with SP 2010

#6470
Anonymous
Anonymous
Participant

Yes, we have made all of the configuration changes exactly as per their documentation, i.e. the changes requested at the bottom of the email. The only thing that looks a bit odd is in the webconfig in the same section requested by step #4, there are 2 entries for name = “Session”, the first is a remove command (which must have been there before) that looks like this <remove name="Session" /> and then their entry at the bottom of the section that appears like <add name="Session" type="System.Web.SessionState.SessionStateModule" />

1.    Under the node, '<configuration><SharePoint><SafeControls>', the following entry should exist.

'<SafeControl Namespace="WA.WebPart" Assembly="WA.WebPart, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2b4b09f1c57c8f0b" TypeName="*" Safe="True" />'

If this entry is not there, please go to the SharePoint administration page and redeploy the Quest Shared Web Parts Solution Package.

2.    Under the node, '<configuration><system.web><httpHandlers>', check if the following entry exists. If not, please add.


'<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />'

3.    Under the node, '<configuration><system.web><httpModules>' for SharePoint 2007 or '<configuration><system.webServer><modules>' for SharePoint 2010, check if the following entry exists. If not, please add.

'<add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />'

4.    In order for the Shared Web Parts to be fully functional you need to enable the session. To do so, please add the following entry under the node, '<configuration><system.web><httpModuels>', for SharePoint 2007 or, '<configuration><system.webServer><modules>', for SharePoint 2010:


'<add name="Session" type="System.Web.SessionState.SessionStateModule" />'

and under the node, '<configuration><system.web><pages>', change the attribute 'enableSessionState' to true.