Loading...

RE: qDiscussionView seems frozen

RE: qDiscussionView seems frozen

Home Forums QuickApps Forum qDiscussionView seems frozen RE: qDiscussionView seems frozen

#6673
Anonymous
Anonymous
Participant

Hi ,

So I've compared our original config, the one changed by our systems dept, and the changes you asked for.  Here's the deal (out of order):

1. In original

3. added as you noted

4. only change was to set EnableSessionState to from false to true

2. In the original, but different than you noted:

We have a later version, which is used in other statements in the config:

<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />

You asked for

<add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />

And

<add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource,Telerik.Web.UI, Version=2009.3.1208.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" verb="*" validate="false" />

Where yours was without version culture or token:

<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />

Next?

 

After you install the product, locate the web.config file for your SharePoint Web application that has the Quest Shared Web Parts installed. You will need to make the following changes to it:

  1. Under the node, '<configuration><SharePoint><SafeControls>', the following entry should exist.
    '<SafeControl Namespace="WA.WebPart" Assembly="WA.WebPart, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2b4b09f1c57c8f0b" TypeName="*" Safe="True" />'

    If this entry is not there, please go to the SharePoint administration page and redeploy the Quest Shared Web Parts Solution Package.

  2. Under the node, '<configuration><system.web><httpHandlers>', check if the following entry exists. If not, please add.


    '<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
    <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />'

  3. Under the node, '<configuration><system.web><httpModules>', check if the following entry exists. If not, please add.

    '<add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />'

  4. In order for the Shared Web Parts to be fully functional you need to enable the session. To do so, please add the following entry under the node, '<configuration><system.web><httpModuels>', for SharePoint 2007 or, '<configuration><system.webServer><modules>', for SharePoint 2010:


    '<add name="Session" type="System.Web.SessionState.SessionStateModule" />'

    and under the node, '<configuration><system.web><pages>', change the attribute 'enableSessionState' to true