Loading...

qDiscussionView seems frozen

qDiscussionView seems frozen

Home Forums QuickApps Forum qDiscussionView seems frozen

  • This topic is empty.
Viewing 26 reply threads
  • Author
    Posts
    • #4957
      Anonymous
      Anonymous
      Participant

      Hi

      There is a readme document that you need to follow in order to make it work properly.

      These are the steps I'm talking about.

      Please follow these steps and let me know how it goes.

      After you install the product, locate the web.config file for your SharePoint Web application that has the Quest Shared Web Parts installed. You will need to make the following changes to it:

      1. Under the node, '<configuration><SharePoint><SafeControls>', the following entry should exist.

        '<SafeControl Namespace="WA.WebPart" Assembly="WA.WebPart, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2b4b09f1c57c8f0b" TypeName="*" Safe="True" />'

        If this entry is not there, please go to the SharePoint administration page and redeploy the Quest Shared Web Parts Solution Package.

      2. Under the node, '<configuration><system.web><httpHandlers>', check if the following entry exists. If not, please add.

        '<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
        <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />'

      3. Under the node, '<configuration><system.web><httpModules>', check if the following entry exists. If not, please add.

        '<add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />'

      4. In order for the Shared Web Parts to be fully functional you need to enable the session. To do so, please add the following entry under the node, '<configuration><system.web><httpModuels>', for SharePoint 2007 or, '<configuration><system.webServer><modules>', for SharePoint 2010:

        '<add name="Session" type="System.Web.SessionState.SessionStateModule" />'

        and under the node, '<configuration><system.web><pages>', change the attribute 'enableSessionState' to true

    • #6668
      Anonymous
      Anonymous
      Participant

      I went out to download the web part but it says it was last updated 12/2010?  I previous post stated that it was updated in 5/2011?

      Thanks.

    • #3962
      Anonymous
      Anonymous
      Participant

      We’re testing the latest version of the qDiscussionView webpart.  It loads the discussion board, but it seems frozen on the first entry.  Clicking on the other rows does nothing. 

      The toolbar does work and you can select the checkboxes, but expanding the tree doesn’t work. 

      I’m using IE9, and I’ve tried compatibility view but that didn’t help.  I’m also seeing the same in Firefox.

      Any ideas?

    • #6684
      Anonymous
      Anonymous
      Participant

      No worires about that.

      The latest the greates I'd say.

      Please let me know if you find any issues.

    • #6669
      Anonymous
      Anonymous
      Participant

      Hi ,

      Thank you – the view is working now.  We had to restart the IIS service after making the changes to the config file.. does that make sense?

      Next problem though: now there's a big space between the toolbar and the grid.  (I've tried to include an image with this post, but I keep getting an error, so I've uploaded a jpg)  The space wasn't there before we made the config changes, and I've tried just about every setting in the ezedit tool, but nothing affects it (I thought it was the filter panel, but nope.)

      Any ideas on this one?

    • #6670
      Anonymous
      Anonymous
      Participant

      Glad to hear that it worked.

      Try to comment out the changes you made in the web.config file and see if the space is still there.

    • #6671
      Anonymous
      Anonymous
      Participant

      Hi ,

      We put back the original web.config, and the space is gone, but the webpart is no longer working… ie back to square one.  (BTW, the space had appeared in IE but not in Firefox.)

    • #6672
      Anonymous
      Anonymous
      Participant

      Now let's put back the web.config changes as I suggested in my previous entry.

      If you have a text comparison tool please compare the original web.config file and the modified one.

      This is just to ensure that nothing else gets modified but our changes.

      After that's done reset iis (if possible) then see what happenes.

    • #6673
      Anonymous
      Anonymous
      Participant

      Hi ,

      So I've compared our original config, the one changed by our systems dept, and the changes you asked for.  Here's the deal (out of order):

      1. In original

      3. added as you noted

      4. only change was to set EnableSessionState to from false to true

      2. In the original, but different than you noted:

      We have a later version, which is used in other statements in the config:

      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />

      You asked for

      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />

      And

      <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource,Telerik.Web.UI, Version=2009.3.1208.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" verb="*" validate="false" />

      Where yours was without version culture or token:

      <add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />

      Next?

       

      After you install the product, locate the web.config file for your SharePoint Web application that has the Quest Shared Web Parts installed. You will need to make the following changes to it:

      1. Under the node, '<configuration><SharePoint><SafeControls>', the following entry should exist.
        '<SafeControl Namespace="WA.WebPart" Assembly="WA.WebPart, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2b4b09f1c57c8f0b" TypeName="*" Safe="True" />'

        If this entry is not there, please go to the SharePoint administration page and redeploy the Quest Shared Web Parts Solution Package.

      2. Under the node, '<configuration><system.web><httpHandlers>', check if the following entry exists. If not, please add.


        '<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
        <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />'

      3. Under the node, '<configuration><system.web><httpModules>', check if the following entry exists. If not, please add.

        '<add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />'

      4. In order for the Shared Web Parts to be fully functional you need to enable the session. To do so, please add the following entry under the node, '<configuration><system.web><httpModuels>', for SharePoint 2007 or, '<configuration><system.webServer><modules>', for SharePoint 2010:


        '<add name="Session" type="System.Web.SessionState.SessionStateModule" />'

        and under the node, '<configuration><system.web><pages>', change the attribute 'enableSessionState' to true

    • #6674
      Anonymous
      Anonymous
      Participant

      Hi

        Is difficult for me to follow the changes, would you mind to send both files (original and changed to accomodate the discussion view) to me by email?

      Thanks,

    • #6675
      Anonymous
      Anonymous
      Participant

      Hi ,

      I had emailed the 2 config files to you… did you get them?  Here they are again:

      Thanks,

      Additional Attachments:

      n

    • #6676
      Anonymous
      Anonymous
      Participant

      Hi

        I didn't get  them by email (I check daily the Spam folder too, maybe the email got block before it reached my Inbox).

      Anyways, I'm going to check them both and let you know.

      Thanks,

    • #6677
      Anonymous
      Anonymous
      Participant

      I checked the files and it looks that you applied only 2 changes (or at leat my tool that I use to check files differences is telling me so)

      n

      <add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

      n

          <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">

      n

      n

      You need to add the missing changes: safe control, the session and the handlers.

      n

      n

      n

      n

      PS

      n

      We just released a newer verison of dicussion webpart, please check the link below

      n

      http://en.community.dell.com/techcenter/sharepoint-for-all/w/wiki/5537.qdiscussionview-freeware-web-part-for-sharepoint-2010

    • #6678
      Anonymous
      Anonymous
      Participant

      Hi ,

      Some of the changes you noted were already in place, so wouldn't show just by looking for the differences.  However… if there's a newer version, we'll start over with that one .  Let's close this thread and keep our fingers crossed that we'll be good to go.

      Thanks,

    • #6679
      Anonymous
      Anonymous
      Participant

      Hi

      n

      n

         Please download the new version from here http://en.community.dell.com/techcenter/sharepoint-for-all/w/wiki/5537.qdiscussionview-freeware-web-part-for-sharepoint-2010 and give it a try.

      n

      Please note that you still need to perform the web.config modifications manually in order to have it working.

      n

      Please let me know hot it goes.

      n

      n

      n

      I'd suggest you to try it first on a aclean test env. and once you have it working there move install it on a final server(s).

      n

      n

      This question is "Assumed Answered". Please mark it answered or helpfull if you consider approperiate so other people can take advantage of this tread. Thanks again,.

    • #6680
      Anonymous
      Anonymous
      Participant

      Hi ,

      We will install the update.  Do you recommend uninstalling the previous version first?  The release notes do not mention whether this is required / recommended.

    • #6681
      Anonymous
      Anonymous
      Participant

      Hi

        Yes  we need to uninstall the previous version then install the new one.

      Please let me know how it goes.

      Thnsks,

    • #6682
      Anonymous
      Anonymous
      Participant

      Hi ,

      We tried installing the version 5.6 at the link you'd posted: on second look, it appears that this viewer might be for SharePoint 2010 only… is that the case?  We've had no luck installing it: we're on MOSS 2007 (64 bit)

      I see a version 5.4 version posted on the site: when I started this thread we were trying to install v 5.2.  Which version should we be installing?

      Thanks,

    • #6683
      Anonymous
      Anonymous
      Participant

      Hi

      The link I posted is to SharePoint 2010 version. You won't be able to install it on MOSS 2007.

      What you need to do is download a version for SP2007 64 bit.

    • #4759
      Anonymous
      Anonymous
      Participant

      I am also having this problem – installed on SharePoint 2010 64-bit running on Windows 7.

      Everything is installed but I get no expand / collapse on the post categories and am unable to highlight a category other than the initial one (which appears highlighted when the page loads).

      I've made all the changes to the web.config that are described.

      Thanks for any help!

    • #6615
      Anonymous
      Anonymous
      Participant

      Do you see any javascript errors in your browser when the page loads and when you try to select a discussion?

      Please note that depending on your browser version you may need to enable js errors to show up n the IE settings.

    • #6621
      Anonymous
      Anonymous
      Participant

      I tried again and it worked ok for me just performing those 4 steps I mentioned.

      There was no need for me to perform the change in the link you provided.

      Our environments are not identical for sure and that could be the cause.

      Do you have any other product that uses a DevExpress component?

    • #6616
      Anonymous
      Anonymous
      Participant

      Yes. The error is 'ASPxClientTreeList is undefined.'

      discussionListErrorLeft.jpg

    • #6617
      Anonymous
      Anonymous
      Participant

      Hi

      After you install the product, locate the web.config file for your SharePoint Web application that has the Quest Shared Web Parts installed. You will need to make the following changes to it:

      Please let me know how that goes.

      -Under the node, '<configuration><SharePoint><SafeControls>', the following entry should exist.
      '<SafeControl Namespace="WA.WebPart" Assembly="WA.WebPart, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2b4b09f1c57c8f0b" TypeName="*" Safe="True" />'

      If this entry is not there, please go to the SharePoint administration page and redeploy the Quest Shared Web Parts Solution Package.

      -Under the node, '<configuration><system.web><httpHandlers>', check if the following entry exists. If not, please add.

      '<add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" validate="false" />
      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />'

      -Under the node, '<configuration><system.web><httpModules>', check if the following entry exists. If not, please add.

      '<add name="ASPxHttpHandlerModule" type="DevExpress.Web.ASPxClasses.ASPxHttpHandlerModule, DevExpress.Web.v9.3, Version=9.3.3.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />'

      -In order for the Shared Web Parts to be fully functional you need to enable the session. To do so, please add the following entry under the node, '<configuration><system.web><httpModuels>', for SharePoint 2007 or, '<configuration><system.webServer><modules>', for SharePoint 2010:

      '<add name="Session" type="System.Web.SessionState.SessionStateModule" />'

      and under the node, '<configuration><system.web><pages>', change the attribute 'enableSessionState' to true

    • #6618
      Anonymous
      Anonymous
      Participant

      I got this to work — all of the changes that you describe above were already added.

      I had to add a line to both the modules and handlers sections under  <configuration><system.webServer>. This is described in this post – http://documentation.devexpress.com/#AspNet/CustomDocument7540. (Be sure and change the version number to 9.3.3.0.)

      I assume that this is required for IIS v.7.5.

    • #6619
      Anonymous
      Anonymous
      Participant

      Thanks for that . This helped me out. Although I didn't need to turn on Session State.

    • #6620
      Anonymous
      Anonymous
      Participant

      I'm glad to hear that.

      Can you please mark the answer as correct or helpfull so other people can benefit?

      Thanks,

Viewing 26 reply threads

You must be logged in to reply to this topic.