Loading...

qDiscussionView ezEdit error.

qDiscussionView ezEdit error.

Home Forums QuickApps Forum qDiscussionView ezEdit error.

  • This topic is empty.
Viewing 22 reply threads
  • Author
    Posts
    • #7252
      Anonymous
      Anonymous
      Participant

      Hi Sean,
      Thanks for the reply. I didn't pay for the web parts so I guess I'm running the shareware (free) version that I downloaded from your site. The version that I'm running is:
      Product Version: 5.2 (Build 2010.03.05)
      I modified the web.config per your instruction except that I don't have the <SharePoint> tag. But not sure where to get the debug information. Please advice.
      -Jackson

    • #4865
      Anonymous
      Anonymous
      Participant

      Hi

      Were you trying the qDiscussionView as shareware or using it as part of licensed web parts? What is the version and build number (accessible from web part context menu About dialog)? This can help identify the issue as different installers for shareware and licensed install were provided.

      You will have to change the web.config settings to bring more debug info for this problem. Please check the followings:

      1. Locate the 12 hive under %Program Files%/Common Files/Microsoft Shared/web server extensions/12/TEMPLATE/Layouts/
      2. Modify the web.config (make a backup first) and locate <system.web> tag and <compilation> tag underneath it (if not exists, please add) make sure you have <compilation debug="true"…> where "debug" attribute is set to "true".
      3. Locate <customErrors> tag underneath <system.web> tag and set mode to "Off".
      4. Locate <SharePoint> tag underneath <configuration> if exists and make sure CallStack attribute is set to "true".

      Sean

    • #7253
      Anonymous
      Anonymous
      Participant

      I'm having the exact same problem. Any help would be greatly appreciated.

    • #7254
      Anonymous
      Anonymous
      Participant

      A bug seemed to have been introduced where the session value is checked and if the site web configuration file does not have session enabled, it throws an exception. We will update the code and provide an updated download bits. In the meantime, try enabling the session to see if it helps (web.config <pages> tag with enableSessionState="true"). Note this is optional, it does not require you to enable the session when this bug is fixed.
      I will update this thread once we have updated the download link.

    • #7256
      Anonymous
      Anonymous
      Participant

      To enable session for ASP.NET application, you would set the attribute "enableSession" of element configuration/system.web/pages, an example is given below from a default SharePoint web application configuration file.

      <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">
      <namespaces>
      <remove namespace="System.Web.UI.WebControls.WebParts" />
      </namespaces>
      <tagMapping>
      <add tagType="System.Web.UI.WebControls.SqlDataSource, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" mappedTagType="Microsoft.SharePoint.WebControls.SPSqlDataSource, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      </tagMapping>
      </pages>

      Also you need to add http module entry into element configuration/system.web/httpModules, an example is given below.

      <httpModules>
      <clear />

      <add name="Session" type="System.Web.SessionState.SessionStateModule" />
      </httpModules>

    • #7255
      Anonymous
      Anonymous
      Participant

      Hi there,
      I can't seemed to find <pages> tag in web.config. Should I created it? If so is this the synthax? Thanks.
      <pages>
      enableSessionState="true"
      </pages?

    • #7261
      Anonymous
      Anonymous
      Participant

      editing the web.config as per your instructions above fixed the issue for me; many thanks 4 that! Looking forward to the bug fix, though, since I don't wish to have the session state enabled. cheers

    • #7262
      Anonymous
      Anonymous
      Participant

      Here is the code from my web.config file:
      <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
      <configuration>
      <system.web>
      <compilation batch="false" batchTimeout="600" maxBatchSize="10000" maxBatchGeneratedFileSize="10000" />
      <httpHandlers>
      <add verb="*" path="*.aspx" type="System.Web.UI.PageHandlerFactory, System.Web, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
      </httpHandlers>
      <customErrors mode="On" />
      <httpRuntime executionTimeout="3600" />
      <globalization fileEncoding="utf-8" />
      </system.web>
      <location path="upload.aspx">
      <system.web>
      <httpRuntime maxRequestLength="2097151" />
      </system.web>
      </location>
      <location path="ctdmsettings.aspx">
      <system.web>
      <httpRuntime maxRequestLength="2097151" />
      </system.web>
      </location>
      <location path="ChangeContentTypeOptionalSettings.aspx">
      <system.web>
      <httpRuntime maxRequestLength="2097151" executionTimeout="3600" />
      </system.web>
      </location>
      <location path="MngField.aspx">
      <system.web>
      <httpRuntime executionTimeout="3600" />
      </system.web>
      </location>
      <location path="fldpick.aspx">
      <system.web>
      <httpRuntime executionTimeout="3600" />
      </system.web>
      </location>
      <location path="ManageContentTypeField.aspx">
      <system.web>
      <httpRuntime executionTimeout="3600" />
      </system.web>
      </location>
      <system.web>
      <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">
      <namespaces>
      <remove namespace="System.Web.UI.WebControls.WebParts" />
      </namespaces>
      <tagMapping>
      <add tagType="System.Web.UI.WebControls.SqlDataSource, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" mappedTagType="Microsoft.SharePoint.WebControls.SPSqlDataSource, Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      </tagMapping>
      </pages>
      <httpModules>
      <clear />
      <add name="Session" type="System.Web.SessionState.SessionStateModule" />
      </httpModules>
      </system.web>
      </configuration>

    • #7258
      Anonymous
      Anonymous
      Participant

      The fix is on the way but for now you would have to manually change web.config to enable session by following the previous responses. Were you having issues after you enabled the session?

    • #7259
      Anonymous
      Anonymous
      Participant

      I copied and pasted the above and reset IIS but it did not seem to have any effect.

    • #7257
      Anonymous
      Anonymous
      Participant

      Has there been any luck fixing the bug? I too have had the same problem and have been unable to get the enableSession workaround to resolve it. Thanks in advance!

    • #7260
      Anonymous
      Anonymous
      Participant

      Can you attach your web.config here for us to look at?

    • #7265
      Anonymous
      Anonymous
      Participant

      So since I do not have SQL Server, I used InProc but that did not work. I just get a runtime error.

      <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
      <configuration>
      <system.web>
      <compilation batch="false" batchTimeout="600" maxBatchSize="10000"
      maxBatchGeneratedFileSize="10000" />
      <httpHandlers>
      <add verb="*" path="*.aspx" type="System.Web.UI.PageHandlerFactory, System.Web,
      Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
      </httpHandlers>
      <customErrors mode="On" />
      <httpRuntime executionTimeout="3600" />
      <globalization fileEncoding="utf-8" />
      </system.web>
      <location path="upload.aspx">
      <system.web>
      <httpRuntime maxRequestLength="2097151" />
      </system.web>
      </location>
      <location path="ctdmsettings.aspx">
      <system.web>
      <httpRuntime maxRequestLength="2097151" />
      </system.web>
      </location>
      <location path="ChangeContentTypeOptionalSettings.aspx">
      <system.web>
      <httpRuntime maxRequestLength="2097151" executionTimeout="3600" />
      </system.web>
      </location>
      <location path="MngField.aspx">
      <system.web>
      <httpRuntime executionTimeout="3600" />
      </system.web>
      </location>
      <location path="fldpick.aspx">
      <system.web>
      <httpRuntime executionTimeout="3600" />
      </system.web>
      </location>
      <location path="ManageContentTypeField.aspx">
      <system.web>
      <httpRuntime executionTimeout="3600" />
      </system.web>
      </location>
      <system.web>
      <sessionState mode="Inproc" cookieless="false" timeout="20"/>
      </sessionState>
      <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true"
      validateRequest="false"
      pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter,
      Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
      asyncTimeout="7">
      <namespaces>
      <remove namespace="System.Web.UI.WebControls.WebParts" />
      </namespaces>
      <tagMapping>
      <add tagType="System.Web.UI.WebControls.SqlDataSource, System.Web, Version=2.0.0.0,
      Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
      mappedTagType="Microsoft.SharePoint.WebControls.SPSqlDataSource, Microsoft.SharePoint,
      Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      </tagMapping>
      </pages>
      <httpModules>
      <clear />
      <add name="Session" type="System.Web.SessionState.SessionStateModule" />
      </httpModules>
      </system.web>
      </configuration>

    • #7263
      Anonymous
      Anonymous
      Participant

      In your web.config, check under <system.web> and you should have an entry like following exists to make sure we can enable ASP.NET Session State. I did not seem to find in your post but I am not sure if you have included everything. You will need to specify how session state is implemented and below is using SQLServer to store session state and you could have in-state session service as well.

      <sessionState mode="SQLServer" timeout="60" allowCustomSqlDatabase="true" partitionResolverType="Microsoft.Office.Server.Administration.SqlSessionStateResolver, Microsoft.Office.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

    • #7264
      Anonymous
      Anonymous
      Participant

      Hi, I included everything. I am running WSS 3.0 on Windows 2003 using the Windows Internal Database option.

    • #7266
      Anonymous
      Anonymous
      Participant

      Ok, I got it working. I had been trying to add the code in web.confg under the path: C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS
      I changed this back to what it originally was.
      Then I went to IIS and went to the Home DIrectory tab for the Web Site of my site and found the path to my site. I opened up the web.config file at that location and it already contained all of the code you had said I need to add. So I uncommented out : <!–<add name="Session" type="System.Web.SessionState.SessionStateModule"/> –>
      Then I changed <pages enableSessionState to True.
      I did not see any entry for sessionstate mode= so I just left it alone and did not enter one. I then went back to my site and added the web part. It worked!
      Thank you for all of your help!!! Now the fun begins to see what this baby can do 🙂

    • #7267
      Anonymous
      Anonymous
      Participant

      I'm sorry – I'm a complete noob
      How do you get this to work? What was the final determination of what the issue is?
      The solution?

      I can at least 'fix' the problem by doing this:
      http://sharepointservices.wordpress.com/2008/09/30/failure_adding_web_part_in_sharepoint/

    • #7268
      Anonymous
      Anonymous
      Participant

      The main thing is to make sure you are editing the correct web.config file. I wasted so much time because I was editing the wrong file.
      1. Find the right file by going to IIS and go to the web site SP is installed on. Right click on do properties. Go to the Home DIrectory Tab. You will find the Local Path. This shows you where the correct web.confog file is.
      2. Find and uncommented out : <!–<add name="Session" type="System.Web.SessionState.SessionStateModule"/> –>
      3. Find the line that starts with: <pages enableSessionState="false"
      4. Change it to: <pages enableSessionState="true"
      5. Note that the rest of the line in step 3&4 stays the same, just change the one parameter from false to true!
      6. Restart IIS just to be sure.
      7. Add the webpart.
      That is what worked for me.

    • #7269
      Anonymous
      Anonymous
      Participant

      Thank you.
      I have IIS Manager open and can see the web.config for the site parent. Is that ok?
      How do I make a copy before I edit?

    • #7270
      Anonymous
      Anonymous
      Participant

      ok – I see the properites of the file in IIS.

      I have made a copy by going to that directory via Explorer and copying the file to a backup directory I have created.
      So I don't edit the doc from IIS, I just double click from the directory I have naviaged to, correct?
      Also, this is the parent of all my team sites (My Sites is on a different port). Should I edit this web.config file? Will this then fix the problem for all sub sites of the parent?
      Thanks for your help!

    • #7271
      Anonymous
      Anonymous
      Participant

      I had to restart IIS 2x.
      When I make too many or certain customizations (ezedit), I still get the error. It looks like it's working but then I get the error.
      Out of curiousity, why are these items in the web.config commented out and/or set to false?
      What do you suggest I do next?

    • #3858
      Anonymous
      Anonymous
      Participant

      I’ve got qDiscussionView installed and activated. When I tried to configure it using ezEdit I got the following error: “An unexpected error has occurred. Web Parts Maintenance Page: If you have permission, you can use this page to temporarily close Web Parts or remove personal settings. For more information, contact your site administrator.” Checked the event log and it seemed the install went fine. Any ideas? I have WSS 3.0 on W3K 32bit. Thanks.

    • #7272
      Anonymous
      Anonymous
      Participant

      ok – I uninstalled and reinstalled the web part.
      I think I get errors when I make changes to the search settings/options in the web part.
      If I make all other changes (I think) the web part works. I think this may be an issue I have with my dev environment.
      One more question: How do I switch views now? No longer an option?

      Thanks again for your help!

Viewing 22 reply threads

You must be logged in to reply to this topic.