Loading...

qList performance with large number of list items

qList performance with large number of list items

Home Forums QuickApps Forum qList performance with large number of list items

  • This topic is empty.
Viewing 6 reply threads
  • Author
    Posts
    • #5440
      Anonymous
      Anonymous
      Participant

      Hi Edward

      It is sure a surprise to hear that it took 20 to 40 seconds to load a page with couple of web parts fetching 500 some list items. I would first isolate the components involved by removing the web parts on the page and measure the performance one by one to find out which Web Part on the page is actually causing the performance issue. Then we can look closely to see what could be the cause.

      In the past we have cutomers experienceing performance issue related to qListView. There are tips and best practices that can go with the configugration of the qListView and design of the lists connected. We can get you that. In one particular case, we also found out that a particular version of IE browser plays an important role, where using a different version of IE or chrome or Firefox does not have the same performance issue but that is the only case we have run into.

    • #5927
      Anonymous
      Anonymous
      Participant

      The browser type doesn't seem to change anything.

      I have 3 web parts set up the exact same way on two different sites, connected to the exact same list template. One site has 1200 list items the other has 25 right now. The site with 25 items loads in 5-10 sconds. The site with 1200 items loads in 25-35 seconds.

      3 web parts:

      1. qlist view, in list searcher mode. About 8 fields selected.

      2 and 3 qchart view web parts, 2 of them, displaying data in qlist web part. One a pie chart other a bar chart. e fields-8 total.

      Page is the same, site collection is the same. Data is the same, but one loads properly the other takes forever.

    • #5926
      Anonymous
      Anonymous
      Participant

      For a list of 25 items, loading in 5 to 10 seconds should be considered slow as well as 25 to 35 seconds for loading 1,200 items. Something needs to be looked at your setup to determine what is the contributing factors to the performance issue. Please open a support ticket with us so we can be online with you to investigate the issue.

    • #5925
      Anonymous
      Anonymous
      Participant

      Hi Chen,

      I would also be interested in the outcome of your investigation as we have had a performance issue that seems to deteriorate as the number of items in a list increases.

    • #4414
      Anonymous
      Anonymous
      Participant

      We have followed all the recommended performance set up guidelines that are published to follow on the use of SharePoint and these products, but we still get very slow performance when loading a one (1) qilist web part with over 500 list items, and one (1) to two (2) qchart web part(s) loaded on a single page. It can take 20-40 seconds to load the page. Again we have list searcher enabled and other documented product features enabled we have found published.

      Have others experienced slow page loads, and has anyone found a tip/trick or best practice to improve page load times.

    • #5905
      Anonymous
      Anonymous
      Participant

      Hi ,

      I have emailed the service request details to you.

    • #5924
      Anonymous
      Anonymous
      Participant

      If you could share more info in your situation, that would be great. We have not started investigating yet but in this particular case, we need to isolate contributing factors and look close to SharePoint list setup, web part configuration. Your situation may be different. If it is a single qListView web part on the page connecting to the list, there may be other things we should look into.

Viewing 6 reply threads

You must be logged in to reply to this topic.