Loading...

qListForm with Sytem Integration Field causing blank entries to be created in the list

qListForm with Sytem Integration Field causing blank entries to be created in the list

Home Forums QuickApps Forum qListForm with Sytem Integration Field causing blank entries to be created in the list

  • This topic is empty.
Viewing 3 reply threads
  • Author
    Posts
    • #5265
      Anonymous
      Anonymous
      Participant

      Hi Hunar,

        What's your QWP and SharePoint version?

    • #5977
      Anonymous
      Anonymous
      Participant

      Hi ,

      We're using SharePoint 2010 and QWP Version 5.7.

      Hunar

    • #4310
      Anonymous
      Anonymous
      Participant

      Hi,

      We have setup a qListForm with a System Integration field that refers to the Catalog that is defined for that qListForm.

      It is a required field.

      Ideally, unless there is data in the field, the form should not save and keep prompting the “Required” message till the field has been valued. Also no entry must be created in the list unless the form has been saved.

      The form does not save, and it does prompt the Required message but at the same time it keeps creating blank entries in the list every time the Save button is hit.

      Is there anything that we might be missing out?

      Thanks,

      Hunar Singh

    • #5978
      Anonymous
      Anonymous
      Participant

      Hi Hunar,

      2 things to try:

      #1 see what's your default operation on the form (See Catalog-Entity->Edit see the column default. IF none f that is checked then the 1st entry is the default) and that operation gets executed (also depends of your Form Type (Edit, Display, New..).

      #2 add condition to your stored procedure (if you use the to interact with the data).

      Please let me know how that goes.

Viewing 3 reply threads

You must be logged in to reply to this topic.